Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
software:linux:beagleboneblue [2017-06-22 16:49]
Graf Urs
software:linux:beagleboneblue [2019-10-14 10:44] (aktuell)
Graf Urs
Zeile 1: Zeile 1:
-======Linux on BeagleBone ​Blue======+====== Linux on Beaglebone ​Blue Board ====== 
 +Useful information about the board can be found under [[:​embedded_systems:​ti_sitara_am335x:​beaglebone_blue:​start|Beaglebone Blue]].
  
-https://​eewiki.net/​display/​linuxonarm/​BeagleBone+Blue 
  
-===== EEROS on BeagleBoneBlue ​===== +===== RT-Kernel ​===== 
-Fetch example application and build scripts on host.+Check if there is already a RT-Kernel:
 <​code>​ <​code>​
-$ git clone https://​github.com/​ntb-ch/​BeagleBoneBlue.git+uname -r
 </​code>​ </​code>​
-Get EEROS and the hardware wrapper library.+ 
 +If not, download:
 <​code>​ <​code>​
-$ cd BeagleBoneBlue +sudo apt-get install linux-image-4.4.49-ti-rt-r89
-./clone.sh+
 </​code>​ </​code>​
 +Do not use a newer one. Robotics Cape won't work anymore (ERROR: missing PINMUX driver).
  
-The library for the roboticscape must be manually compiled. Change into:+Reboot and delete ​the old kernel:
 <​code>​ <​code>​
-$ cd robotics_cape_installer/​libraries+sudo apt remove --purge linux-image-4.4.54-ti-r93
 </​code>​ </​code>​
-and edit the ''​Makefile''​ therein. Change the following to lines from  
-<​code>​ 
-CC := gcc 
-LINKER := gcc 
-</​code>​ 
-to 
-<​code>​ 
-CC := arm-linux-gnueabihf-gcc-4.9 
-LINKER := arm-linux-gnueabihf-gcc-4.9 
-</​code>​ 
-This is necessary because we work on the host and must make sure to choose the right cross compiler. You must install this compiler with 
-<​code>​ 
-$ sudo apt-get install g++-4.9-arm-linux-gnueabi 
-</​code>​ 
-Now you can create the roboticscape library with 
-<​code>​ 
-$ make 
-</​code>​ 
-