AVR Projekt anlegen

Projekt erstellen

Wie unter Erste Schritte beschrieben, die C/C++ Perspektive öffnen.

  1. File → New → C Projekt wählen.
    newcproject.jpg
  2. Projektname eintragen
  3. Project type: AVR Cross Target Application → Empty Project wählen
  4. Als Toolchain AVR-GCC Toolchain wählen
  5. 2 mal Next wählen
    newavrproject.jpg
  6. Unter MCU Type den korrekten AVR wählen (z.B. ATmega16U4 für SEA14-Board oder AT90USB1287 für CombiExp.-Board)
  7. Bei MCU Frequency muss der Wert auf 8 MHz (8000000) geändert werden.
    avrtargetchooser.jpg
  8. Finish wählen
  9. Im Project Explorer befindet sich nun das leere Projekt.
  10. Rechtsklick auf den erstellten Projektordner und Properties öffnen
  11. Unter C/C++ Build → Settings → Additional Tools in Toolchain den Haken bei Generate Hex file for Flash memory setzen und mit OK bestätigen
    avrprojectsettings.jpg
  12. Über File → New → Source Folder den New Source Folder Dialog starten
    newsrcfolder.jpg
  13. Dem Folder eienen Namen geben und Finish wählen.
    foldername.jpg
  14. Im Project Explorer ist der Source Folder sichtbar.
    empty_srcfolder.jpg
  15. Mittels Rechtsklick auf dem Source Folder → New → Source File den New Source File Dialog starten.
    newsource.jpg
  16. Dateiname mit Datei-Extension ('.c') setzten und mit Finish bestätigen.
    filename.jpg

Projekt bilden

Nach einmaligen Bilden unter Project → Build All wird das Projekt standardmässig bei jedem Speichervorgang neu gebildet. Falls dies manuell geschehen soll, muss die Option Project → Build Automatically ausgeschaltet werden. Anschliessend können das Projekt oder auch einzelne Files unter Project gebildet werden.

Projekt auf das Target laden

Mittels Flip

  1. Unter Start → Programs → Informatik → Atmel AVR Tools → Flip 3.4.1 starten
  2. Auf IC Symbol klicken und korrektes Device auswählen (ATmega16U4 für SEA14-Board oder AT90USB1287 für CombiExp etc.) → OK
  3. Hex File auswählen unter File → Load Hex File
  4. Target in den Bootloader Modus umschalten. Dazu HWB drücken und gedrückt halten. Anschliessend auf Reset drücken. HWB erst nach dem Reset wieder loslassen
  5. Auf USB Symbol klicken → USB → Open
  6. Anschliessend das Programm mit Run auf das Target laden

Mittels Eclipse

  1. Den Eintrag Open External Tools Dialg auswählen
    runexternal.jpg
  2. Im linken Abschnitt Doppelklick auf Program
  3. Unter Name Download eingeben
  4. In das Feld Location mit Hilfe des „Browse“-Knopfes den Pfad C:\Programme\Atmel\Flip 3.4.1\bin\batchisp.exe einfügen
  5. In das Argument Feld das korrekte Device etc. eintragen z.B. für AT90USB1287: -device AT90USB1287 -hardware USB -operation erase f loadbuffer ${resource_loc} program verify einfügen
  6. Mit Apply → Run bestätigen (Das Run wird nur ausgeführt, damit der Eintrag „Download“ unter runexternalico.jpg erscheint. Die Fehlermeldung die darafhin in der Console ausgegeben wird, ist in diesem Fall normal)
    download-batchisp.jpg
  7. Target in den Bootloader Modus umschalten. Dazu HWB drücken und gedrückt halten. Anschliessend auf Reset drücken. HWB erst nach dem Reset wieder loslassen
  8. Das erstellte Hexfile auswählen und anschliessend auf den schwarzen Pfeil neben runexternalico.jpg klicken und Download auswählen
    rundownload.jpg
  9. in der Konsole sollte nun der Downloadvorgang ausgegeben werden.War dieser erfolgreich sieht die Ausgabe in etwa wie im Bild aus
    downloadoutput.jpg